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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation >Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
This document is intended as supplementary material to HFSS for beginners and advanced
users. It includes instructions to create, simulate, and analyze a silicon spiral inductor model.

This chapter contains the following topic:
l Sample Project - Silicon Spiral Inductor

Sample Project – Silicon Spiral Inductor
In this project, we will use HFSS to create, analyze, and review the results of a 2.5 turn spiral
inductor.

Figure 1-1: Spiral Inductor

This nominal design consists of the following components with their corresponding dimensions
and material properties:

Getting Started with HFSS™: Silicon Spiral Inductor
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l Dielectric Layers: For all, Depth (XSize) = 540 μm, Width (YSize) = 540 μm
o Passivation: Thickness (ZSize) = 0.7 μm, εr = 7.9
o Oxide: Thickness = 9.8um, εr = 4.0
o Substrate: Thickness = 300 μm, εr = 11.9, σ = 10 S/m

where εr is the relative permittivity, and σ is the bulk conductivity of the material.

l Conductors:
o Spiral (M6): Thickness = 2 μm, Trace Width =15 μm, Trace Spacing =1.5 μm,
Inside Radius =60 μm, σ =2.8e7 S/m

o Underpass (M5): Thickness = 0.5 μm, Trace Width =15 μm, σ = 2.8e7 S/m

Figure 1-2: Passivation, Oxide and Substrate

Introduction 1-2
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2 - Set Up the Project
This chapter contains the following topics:

l Launch Ansys Electronics Desktop
l Set General Options
l Insert an HFSS design
l Enable Legacy View Orientations
l Set Model Units (μm)
l Set Solution Type (Terminal)

Launch Ansys Electronics Desktop
For convenience, a shortcut to the Ansys Electronics Desktop (EDT) application is placed on
your desktop during program installation. Optionally, you may want to pin the shortcut to your
Windows Start Menu too. Before proceeding to the next topic, launch EDT and add a blank pro-
ject, as follows:

1. Double-click the Ansys Electronics Desktop shortcut on your desktop (or the
same shortcut on your Start Menu).

The Ansys Electronics Desktop application opens:

Figure 2-1: Ansys EDT Application Launched

Set Up the Project 2-1
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2. If a project is not listed at the top of the Project Manager, click New on the Desktop rib-
bon tab to include one. If the Project Manager window does not appear after launching the
application, go to the Viewmenu and select the Project Manager option.

Note:

Normally, a new, project is added automatically when you launch EDT. If you had
the application open already and closed the model you were working on, you will
have to add a new project manually.

Set General Options
Verify the options to be used for this exercise, as follows:

1. On the Desktop ribbon tab, click General Options.

TheOptions dialog box appears.

2. On the left side of the dialog box, expand the HFSS branch, select Boundary Assign-
ment, and insure that all options in this group are selected:

Figure 2-2: HFSS Boundary Assignment Options

3. Expand the 3D Modeler branch, select Drawing, and ensure that the following two
options are selected:

l Automatically cover closed polylines
l Edit properties of new primitives

Set Up the Project 2-2
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Figure 2-3: 3D Modeler Drawing Options

Note:

The Edit properties of new primitives option causes a Properties dialog box to
appear automatically whenever you create a new object.

Insert HFSS Design
Insert an HFSS design into your new project as follows:

1. On the Desktop ribbon tab, click HFSS (Insert HFSS design). (You do not have to
access the HFSS drop-down menu since the default action is to insert a regular HFSS
design type.)

TheModeler window appears on the desktop, the ribbon advances to the Draw tab, and
HFSSDesignx appears under Projectx in the Project Manager:

Set Up the Project 2-3
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Figure 2-4: HFSS Design Added to the Project

Note:

l Adding an HFSS design modifies the project. In the Project Manager, an
asterisk appears after the project name to indicate that there are unsaved
changes.

l Terminal Network is the default solution type, unless the user has saved a
different default. You will verify the appropriate solution type settings in a
later step.

2. Right-click Projectx at the top of the Project Manager and select Rename from the short-
cut menu.

Set Up the Project 2-4
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3. Type Si_Spiral_Inductor and press Enter.

The file Si_Spiral_Inductor.aedt is saved to your default projects folder.

Rename the Design

You will solve two variations of the spiral inductor design. Rename this design to differentiate it
from the later variant, as follows:

4. Right-click HFSSDesign1 (Terminal Network) in the Project Manager and choose
Rename, change the name to No_Solve_Inside, and press Enter.

Enable Legacy View Orientations
This getting started guide was created based on standard view orientations that were in effect
for version 2023 R2 and earlier of the Ansys Electronics Desktop application. For consistency
between your experience and the views and instructions contained in this guide, select the
Enable Legacy View Orientation option in the 3D UI Options dialog box, as follows:

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Select Enable Legacy View Orientation:

Set Up the Project 2-5
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3. ClickOK.

Changing the view orientation option does not change the model viewpoint that was in
effect at the time.

4. On the Draw ribbon tab, click Orient to change to the Trimetric view, which is the
default legacy view orientation.

You do not have to select Trimetric from theOrient drop-down menu. The default view
appears when you clickOrient.

Although this option can only be accessed once a design is added to a project, it is a global
option. Your choice is retained for all future program sessions, projects, and design types that
use the 3D Modeler or that produce 3D plots of results.

At the end of this guide, you will be prompted to clear the Enable Legacy View Orientation
option, if you prefer to use the view orientation scheme implemented for 2024 R1 and newer ver-
sions going forward.

For a comparison of the legacy and current view orientations, search for "View Options: 3D UI
Options" in the HFSS help. Additionally, views associated with Alt + double-click zones have

Set Up the Project 2-6
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been redefined. The current orientations are shown in the help topic, "Changing the Model View
with Alt+Double-Click Areas."

Set Model Units
Set the length unit for the geometric model as follows:

1. On the Draw ribbon tab, click Units. (   There is no icon associated with this
command.)

The Set Model Units and Max Extent dialog box appears.

2. Choose um (micron or 10-6meter) from the Select units drop-down menu.

Keep the Rescale to new units and Advanced options cleared.

Figure 2-5: Choosing the Length Unit

3. ClickOK.

Verify Solution Type
To verify the solution type and change it if necessary:

1. Using the menu bar, click HFSS > Solution Type.

The Solution Type dialog box appears.

2. Ensure that the solution type and options are set as shown in the following image:

Set Up the Project 2-7
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Figure 2-6: Solution Type Dialog Box

Note:

Terminal solutions calculate the terminal-based S-parameters of multi-conductor
transmission line ports. The S-matrix solutions will be expressed in terms of ter-
minal voltages and currents.

3. ClickOK.

Set Up the Project 2-8
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3 - Construct the Model
This chapter describes how to build the 3D spiral inductor model in HFSS (including drawing the
geometric objects and assigning materials, boundaries, and excitations). The drawing oper-
ations are grouped by dielectric and conductor objects.

The following sections are covered in this chapter:
l Create Dielectric Objects
l Create Conductors
l Assign Boundaries and Excitations

During the construction process, you will hide certain objects to facilitate the drawing of other
objects and then make them visible again afterward.

Create Dielectric Objects
You will begin construction by drawing the nonconducting (dielectric) objects. This subsection
contains the following topics:

l Create Substrate
l Create Oxide
l Create Passivation
l Create Air Body

Create Substrate
To create the substrate, first draw a box freehand as follows:

1. On the Draw ribbon tab, click Draw box.
2. Press F3 to ensure that you are in the point geometry entry mode.

The cursor is accompanied by a black diamond.

3. Click at three random points inside the Modeler window to establish the base corners and
height of an arbitrary box.

After the third click, the Properties dialog box appears.

4. Edit the values in the Command tab of the Properties dialog box to match the following fig-
ure:

Construct the Model 3-1
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Figure 3-1: Substrate Properties – Command Tab

5. On the Attribute tab of the Properties dialog box, make the following changes:
a. Change the Name to Sub.
b. Select Edit from theMaterials drop-down menu.

The Select Definition dialog box appears.

c. Click Add Material.

The View / Edit Material dialog box appears.

d. Edit theMaterial Name, Relative Permittivity, and Bulk conductivity values as
shown in the following figure:

Construct the Model 3-2

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™: Silicon Spiral Inductor

Figure 3-2: Substrate Material Properties

e. ClickOK twice to close the View/Edit Material and Select Definition dialog boxes.
f. Change the Transparent value to 0.6.

Construct the Model 3-3
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Figure 3-3: Substrate Attributes

6. ClickOK to close the Properties dialog box.
7. Press Ctrl+D to fit the model to the viewing area and click in the Modeler window's back-

ground area to clear the selection.

Figure 3-4: Substrate Created

Create Oxide
The oxide layer sits directly on top of the substrate and has the same X and Y size dimensions.
You can snap to two opposite corners of the substrate top to define the base rectangle for the
oxide box. Then, click an arbitrary height point, edit the Z size, and define the name, material,
and appearance properties, as follows:

1. On the Draw ribbon tab, click Draw box. Then:
a. Click the upper left and then the lower right corners of the substrate's top face. The

cursor becomes a black square to indicate the snapping point at the corner vertices.
b. Move the mouse upward slightly and click a third time to define the box height.

2. On the Command tab of the Properties dialog box that appears, change the ZSize value
to 9.8 μm:

Construct the Model 3-4
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Figure 3-5: Oxide Properties – Command Tab

Note:

If you snapped to two different opposing corners, the sign of the Position coordin-
ates, XSize, and/or YSize values may differ from the preceding figure, but the
rectangle should still be correctly sized and placed.

3. On the Attribute tab, do the following:
a. Change the Name toOxide.
b. Choose Edit from theMaterials drop-down menu, click Add Material, and specify

the properties shown below:

Construct the Model 3-5
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Figure 3-6: Oxide Material Properties

c. ClickOK twice to close the View/Edit Material and Select Definition dialog boxes.
d. Change the Color to cyan (column 5, row 2 of the Basic color samples; Red: 0,

Green: 255, Blue: 255).
e. Change the Transparent value to 0.7.

Construct the Model 3-6
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Figure 3-7: Oxide Attributes

4. ClickOK to close the Properties dialog box.
5. Clear the selection.

Figure 3-8: Oxide Created

Create Passivation
The passivation layer sits directly atop the oxide layer and has the same X and Y size dimen-
sions. Therefore, you can draw the box for this object using the same method as you did for the
oxide layer.

1. Draw a box using the upper left and lower right corners of the oxide's top face (selected in
that order) to define the base rectangle and clicking an arbitrary third point to set the
height.

2. In the Command tab of the Properties dialog box that appears after the third click, change
the ZSize value to 0.7 μm:

Construct the Model 3-7
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Figure 3-9: Passivation Properties – Command Tab

3. On the Attribute tab make the following changes:
a. Change the Name to Pass.
b. Choose Edit from theMaterials drop-down menu, click Add Material, and specify

the properties shown below:

Figure 3-10: Passivation Material Properties

c. ClickOK twice to close the View/Edit Material and Select Definition dialog boxes.

Construct the Model 3-8
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d. Change the Color to yellow (column 2, row 2 of the Basic color samples; Red: 255,
Green: 255, Blue: 0).

e. Set the Transparent value at 0.5.

Figure 3-11: Passivation Attributes

4. ClickOK to close the Properties dialog box.
5. Clear the selection.

Figure 3-12: Passivation Created

Construct the Model 3-9
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Create Air Body
You will create a region of air around the spiral inductor and assign a radiation boundary to its
outside faces. A radiation boundary is used to simulate an open problem that allows waves to
radiate infinitely far into space. In this context, the inductor is simulated as if it's in a free space,
uninfluenced by the proximity of other conductors.

The X and Y dimensions of the air body match those of the model's dielectric objects. The bot-
tom of the air body corresponds to the bottom face of the substrate, but the air body extends to a
little more than twice the substrate's height. The reason the air body is allowed to overlap the
dielectric bodies is one of convenience. Radiation boundaries will be applied to the air body
faces in a convenient single operation. If the air body began at the top of the passivation layer,
radiation boundaries would have to be applied to five of the six air body faces and to selected
faces of the substrate, oxide, and passivation layers too, which would be much less convenient.

To create an air body, draw a box and specify its size and location as follows:

1. On the Draw ribbon tab, click Draw box. Then:
a. Click the bottom left corner of the substrate's bottom face (that is, the +X, -Y, -Z

corner of the model) .
b. Click the top right corner of the substrate's bottom face (that is, the -X, +Y, -Z corner

of the model).
c. Click an arbitrary third point above the model to define the air body's height.

2. In the Command tab of the Properties dialog box that appears, specify a ZSize value of
600 μm, as shown in the following figure:

Figure 3-13: Air Body Properties – Command Tab

3. On the Attribute tab, make the following changes:
a. Change the object Name to Air.
b. Select Edit from theMaterial drop-down menu, choose air from the listed materials

in the Select Definition dialog box, and clickOK.
c. Ensure that theMaterial Appearance option is not selected.

Construct the Model 3-10
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d. Set the Color tomedium gray (column 4, row 6 of the Basic color samples; Red:
128, Green: 128, Blue: 128).

e. Set the Transparent value at 0.8.
4. ClickOK to close the Properties dialog box.
5. Press Ctrl+D to fit the view. Also, clear the selection.

The completed dielectric objects should look like the following image:

Figure 3-14: Air Body Created

6. Save your project. (This command is available from any ribbon tab.)

Create Conductors
You will begin the conductors by creating a ground plane at the base of the substrate. Next, hide
the dielectric objects and ground plane to facilitate creation of the remaining conductors. You will
then draw the remaining conducting objects (spiral inductor assembly and ground ring). The fol-
lowing topics and subsections are covered in this section:

Construct the Model 3-11
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l Create Ground Plane
l Hide Dielectric Objects
l Create Spiral Inductor
l Create Ground Ring

Create Ground Plane
You will create the ground plane object from the bottom face of the substrate, as described
below:

1. Ensure that the Modeler window is the active window by clicking anywhere inside it. Then,
press F to switch to the face selectionmode.

2. Click near the bottom edge of one of the substrate's side faces. Then, press B (Next
Behind) twice to select the bottom face.

3. On the Draw ribbon tab, click Surface > Create Object From Face.

Air_ObjectFromFace1 appears underModel > Sheets > Unassigned in the History Tree,
and its attributes appear in the docked Properties window.

4. In the Attribute tab of the docked Properties window, make the following changes:
a. Change the Name toGround and press Enter.
b. Change the Color to orange (column 2, row 4 of the Basic color samples; Red: 255,

Green: 128, Blue: 0).
c. Set the Transparent value to 0 (opaque).

5. Clear the selection.

Construct the Model 3-12
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Figure 3-15: Ground Plane Added

Hide All Existing Objects
Next, hide the existing objects to facilitate drawing the remaining conductors.

1. Ensure that the Modeler window is the active window by clicking anywhere inside it. Then,
pressO to return to the object selectionmode.

2. Press Ctrl+A to select all objects in the window.

Alternatively, you can use the menu bar to click Edit > Select All or Edit > Select All Vis-
ible. You can also right-click in the Modeler window and choose Select Objects > All
Model Objects from the shortcut menu.

3. On the Draw ribbon tab, click Hide selected objects in active view.

Alternatively, you can use the menu bar to click View > Visibility > Hide Selection > All
Views (or Active Views). You can also right-click in the Modeler window and choose
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View > Hide Selection from the shortcut menu.

All objects created thus far are now hidden.

Create Spiral Inductor
The spiral inductor starts out as a polyline following a spiral path. Two methods of drawing the
path are provided. You next define the width and thickness of the conductor and create the
underpass, vias, and feed object. Finally, these objects are united into the complete spiral
inductor object.

The following topics are included in this subsection:

l Define Conductor Material
l Create Offset Coordinate System
l Create Spiral Path
l Assign Width and Thickness
l Create Underpass
l Create Via 1 and Via 2
l Create Feed
l Unite Spiral Objects

Define Conductor Material
Before you create the conductors, define a new default material.

1. At the far right end of the Draw ribbon tab, choose Select from the Default material drop-
down menu. (There is no icon associated with this command, and the current default
material is shown, most likely vacuum.)

The Select Definition dialog box appears.

2. Click Add Material.

The View/Edit Material dialog box appears.

3. Edit theMaterial Name and Bulk Conductivity value as shown in the following figure:
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Figure 3-16: View/Edit Material dialog box

4. ClickOK twice to close the View / Edit Material and Select Definition dialog boxes.

My_Metal is now shown on the Draw ribbon tab as the current Default material.

Define an Offset Coordinate System
Create an offset coordinate system (with the drawing plane parallel to the global XY plane) with
a Z offset at the desired spiral path elevation. The spiral path is located within the thickness of
the Oxide layer at Z = 305.8 μm.

1. On the Draw ribbon tab, click Relative CS. (You do not have to access the Relative
CS drop-down menu to create an offset CS, since Offset is the default action when you
click the Relative CS icon.)

The message Select the origin appears at the left end of the status bar.

2. Press Tab to jump to the X coordinate text box (the first of three near the right end of the
status bar). Specify the origin coordinates for the Offset CS as follows:

l Type 0 in the X text box and press Tab.
l Type 0 in the Y text box and press Tab.
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l Type 305.8 in the Z text box and press Enter.

Note:

Be careful not to move your mouse while entering coordinates in the text boxes,
or the cursor location will override the coordinates you specify.

RelativeCS1 appears under Coordinate Systems in the History Tree, and it is the working
(active) CS, as indicated by the "w" on the icon:

Figure 3-17: RelativeCS1 Defined

3. Save your project.

Create Spiral Path
In this procedure, you will create a spiral polyline path consisting of twelve (12) straight line seg-
ments. You will specify the endpoint coordinates numerically in the status bar's coordinate text
boxes while drawing the polyline.

Note:

Since RelativeCS1 is already defined and is the working CS, you will use it for drawing
the polyline. Since the Z elevation is set via the relative coordinate system's Z offset,
the specified Z coordinate will be zero for all points (rather than 304.8 um).

It is possible to useGlobal as the working coordinate system and then associate the
geometry with RelativeCS1 later on, which would correct the Z elevation of the spiral.
However, that approach would be less efficient.

1. On the Draw ribbon tab, click Draw line.
2. Use the Tab key to navigate among the X, Y, and Z coordinate entry text boxes in the

status bar. Specify the X and Y coordinates from the following table for each point along
the polyline path. The Z coordinate is zero for all points. The global Z elevation is
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predefined according to the offset coordinate system (RelativeCS1). Press Enter when
each set of coordinates is complete to draw the segment and advance to the next point.

Proceed cautiously, as there is considerable room for entry errors. You may want to print a
hard copy of this topic so that you can check off the points as you enter them.

Important:

l Ensure that the drop-down menu to the right of the coordinate text boxes is
set to Absolute for the first point and for all subsequent points:

l Keep your hand off of the mouse when tabbing into the coordinate text
boxes and be very careful not to bump the mouse while typing the coordin-
ates. Any mouse movement will cause the numerical values to revert to
the graphical location of the cursor, resulting in an incorrect line segment.

Point Number X: Y: Z:

1 -67.5 7.5 0

2 -67.5 -67.5 0

3 84 -67.5 0

4 84 84 0

5 -84 84 0

6 -84 -84 0

7 100.5 -84 0

8 100.5 100.5 0

9 -100.5 100.5 0

10 -100.5 -100.5 0

11 117 -100.5 0

12 117 0 0

13 131 0 0
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3. Right-click in the Modeler window and select Done from the short-cut menu to terminate
the polyline at the thirteenth point.

The Properties dialog box appears.

4. In the Attribute tab of the Properties dialog box, make the following changes:
a. Change the Name to Spiral and press Enter.
b. Set the Color to red (column 1, row 2 of the Basic colors samples; Red: 255, Green:

0, Blue: 0).
c. Ensure that the Transparent value is 0 (opaque).

5. ClickOK to close the Properties dialog box.
6. Press Ctrl+D to fit the view. Also, clear the selection.

Figure 3-18: Spiral Path Drawn

The preceding image was captured using the Small coordinate system view option so that
the X axis would not obscure the final, short polyline segment.

7. If your spiral path does not look correct, select each of the CreateLine entries under
Model > Lines > Spiral > CreatePolyline in the History Tree and verify the coordinates
against the preceding table. Correct any values that were specified incorrectly.
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Note:

Each polyline segment (that is, each CreateLine entry in the History Tree) has
two endpoints (Point 1 and Point 2) defined in the Segment tab of the docked
Properties window. Therefore, the point numbering will not match the preceding
table. For each segment, Point 1 is the same as Point 2 of the preceding seg-
ment. Likewise, Point 2 is the same as Point 1 of the next segment. Changing the
coordinates for one segment updates the corresponding point in the adjacent
segment.

8. Save your project.

Assign Width and Thickness to Spiral
To assign a width and thickness to the spiral polyline path, perform the following steps:

1. UnderModel > Lines > Spiral in the History Tree, select CreatePolyline.

The polyline settings appear in the Command tab of the docked Properties window.

2. In the Cross Section part of the CreatePolyline properties, click in the Value column of the
Type row and select Rectangle from the drop-down menu.

Additional items appear in the docked Properties window.

3. Specify the following settings:
a. Width/Diameter = 15 μm
b. Height = 2 μm
c. Press Enter.
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Figure 3-19: Polyline Cross Section Properties

The spiral is assigned the width and thickness that you specified.

4. Press Ctrl+D to fit the view. Also, clear the selection.

Figure 3-20: Updated Spiral

Create Underpass
The underpass is a conductor that is 75 μm long x 15 μm wide x 0.5 μm thick. There needs to be
a gap of 0.8 μm between the bottom face of the spiral and the top face of the underpass. Since
the spiral is 2 μm thick, its bottom face is 1 μm below the RelativeCS1 drawing plane. Therefore,
the top of the underpass must have a Z elevation of -1.8 μm. You will draw a box with this Z
coordinate in its Position value and with a ZSize of -0.5 μm.

1. Ensure that RelativeCS1 is still the working coordinate system:

Figure 3-21: Verifying Working Coordinate System (W on Icon)

2. On the Draw ribbon tab, click Draw box.
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3. Click three different points to draw an box with an arbitrary size and location.

After third click, the Properties dialog box appears.

4. In the Command tab of the Properties dialog box, specify the settings shown in the fol-
lowing figure:

Figure 3-22: Underpass Properties – Command Tab

5. On the Attribute tab, change the object Name to Underpass and clickOK to close the
Properties dialog box.

Note:

The object appearance settings (color and transparency) do not matter. In a later
step, you will unite the objects comprising the spiral inductor assembly. At that
time, all objects will assume the material and appearance of the first object selec-
ted for the Unite operation.

6. Clear the selection.

Your model should look like the following image:
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Figure 3-23: Underpass Created

Create Vias
You will create two vias, one at each end of the underpass. Via 1 connects the spiral inductor to
the underpass. Via 2 connects the underpass to the feed (not yet drawn).

If the first two points you specify when drawing a box differ in all three coordinates (X, Y, and Z),
the length, width, and height are defined with only those two points, and a third click is not
needed. You will take advantage of that functionality, and two snap points on existing geometry,
to draw the first via. In order to click a second point that's not on the same plane as the first one,
you must switch from the In Plane to the 3Dmovement mode while drawing the box.

Create Via 1:

Draw a box as follows:

1. Zoom in closely to the area where the spiral will connect to the underpass. The gap
between these objects is small, and a tight zoom area is helpful in snapping to the correct
vertices.

2. On the Draw ribbon tab, click Draw box.
3. Click the vertex indicated in the following image:
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Figure 3-24: First Point of Via 1 Box

4. Right-click in the Modeler window and selectMovement Mode > 3D from the shortcut
menu.

5. Click the point indicated in the following figure to simultaneously define the length, width,
and height of the box:

Figure 3-25: Second Point of Via 1 Box (3D Drawing Mode)

After the second click, the Properties dialog box appears.

6. On the Attribute tab of the Properties dialog box, change the Name to Via1 and then click
OK.
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7. Clear the selection.

The model should now look like the following figure:

Figure 3-26: Via 1 Created

Create Via 2:

Draw another box using one existing snapping point and enter a second point in the coordinate
entry text boxes, as follows:

8. Pan the model view to see the opposite end of the underpass.
9. On the Draw ribbon tab, click Draw box.
10. Click the point indicated on the following figure:
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Figure 3-27: First Point of Via 2 Box

11. Type the following coordinates in the status bar's coordinate entry text boxes and then
press Enter:

l dX: 15
l dY: 15
l dZ: 0.8

12. On the Attribute tab of the Properties dialog box, change the Name to Via2 and clickOK.
13. Clear the selection.
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Figure 3-28: Via2 Created

Create Feed
Draw the Feed object in the same way that you drew Via 2:

1. On the Draw ribbon tab, click Draw box.
2. Click the point indicated on the following figure:
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Figure 3-29: First Point of Feed Box

3. Type the following coordinates in the status bar's coordinate entry text boxes and then
press Enter:

l dX: -22
l dY: 15
l dZ: 2

4. On the Attribute tab of the Properties dialog box, change the Name to Feed and clickOK.
5. Clear the selection.
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Figure 3-30: Feed Created

Unite Spiral Objects
You will now unite the spiral inductor objects.

1. Press Ctrl+D to fit the visible objects to the viewing area.
2. UnderModel > Solids > My_Metal in the History Tree, select Spiral.
3. Hold down the Ctrl key and also select Feed, Underpass, Via1, and Via2.
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Figure 3-31: Selecting Objects to Unite

Note:

The order in which you select the objects determines the name of the united struc-
ture, the material, and the material appearance. By selecting the Spiral object
first, the united structure will be named Spiral and will have all of the Spiral attrib-
utes. If you were to select Feed first, the united structure would be named Feed
and have that objects attributes.

4. On the Draw ribbon tab, click Unite.
5. Clear the selection.

There is now only one object, Spiral, underMy_Metal in the History Tree, and the model
appearance should be as shown below:
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Figure 3-32: United Spiral Object

Note:

The conductive material is represented by a boundary condition that eliminates
the need to solve inside the metal.

6. Save your project.

Create Ground Ring
A ground ring surrounds the spiral conductor. Before drawing the ground ring, you will create a
second offset coordinate system and define a new default material. You will then draw two
boxes, a large box and a smaller one within it. You will create the ring by subtracting the smaller
box from the larger one. Finally, you will add extensions for connecting the ground ring to the
spiral inductor sources and then unite the objects.

This subsection consists of the following topics.

l Create a Second Offset CS
l Define Ground Ring Material
l Create Outer Box
l Create Inner Box
l Complete the Ring
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l Create Extensions
l Unite Ring and Extensions

Create a Second Offset CS
To facilitate drawing of the ground ring and its extensions, you will define a second offset coordin-
ate system.

RelativeCS1 has a Z coordinate (elevation) that corresponds to the middle of the thickness of
the spiral inductor and feed. You drew the spiral polyline, which was the basis of the inductor, at
the middle of its planned thickness. Then, you applied the width and thickness to the polyline
after drawing it. You will draw the ground ring and its extensions as boxes. For the elevation of
the base rectangles to correspond with the elevation at the bottom face of the spiral and feed,
the new coordinate systemmust have a -1 μm Z-coordinate relative to RelativeCS1.

1. Ensure the RelativeCS1 is still the working coordinate system.

2. On the Draw ribbon tab, click Relative CS. (You do not have to access the Relative
CS drop-down menu. Offset is the default action when you click the Relative CS icon.)

The message Select the origin appears at the left end of the status bar.

3. Press Tab to jump to the X coordinate text box. Specify the origin coordinates for the new
Offset CS as follows:

l Type 0 in the X text box and press Tab.
l Type 0 in the Y text box and press Tab.
l Type -1 in the Z text box and press Enter.

Note:

Be careful not to move your mouse while entering coordinates in the text boxes,
or the cursor location will override the coordinates you specify. The absolute
coordinates you enter are based on the working coordinate system, not the
Global one.

RelativeCS2 appears under Coordinate Systems in the History Tree, and it is the working
CS, as indicated by the "w" on the icon:
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Figure 3-33: RelativeCS2 Defined

Define Ground Ring Material
1. On the Draw ribbon tab, choose Select from the Default material drop-down menu. (My_

Metal is currently shown as the default material.)

The Select Definition dialog box appears.

2. Type pec in the Search by Name text box.

In the list of library materials, pec (perfect electrical conductor) is selected.

Figure 3-34: Specifying Ground Ring Material

3. ClickOK to close the dialog box.

All new objects you draw will be assigned the pec material until the default is changed
again.

Create Outer Box
To create a ground ring, first draw the outer box freehand.
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1. On the Draw ribbon tab, click Draw box.
2. Click at three random points to draw a box of arbitrary size and location.

The Properties dialog box appears.

3. On the Command tab of the Properties dialog box, edit the values as shown in the fol-
lowing figure:

Figure 3-35: Outer Box Properties – Command Tab

4. On the Attribute tab, make the following changes:
a. Change the Name toGND_Ring and press Enter.
b. Ensure that theMaterial Appearance option is not selected.
c. Set the Color to orange (column 2, row 4 of the Basic color samples; Red: 255,

Green: 128, Blue: 0).
d. Set the Transparent value at 0 (opaque).

5. ClickOK to close the Properties dialog box.
6. Press Ctrl+D to fit the view.
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Figure 3-36: Outer Box Drawn

Create Inner Box
You will create an inner box to be subtracted from the outer box you just drew. The result will be
a rectangular ring surrounding the spiral inductor.

To create the inner box, do as follows:

1. On the Draw ribbon tab, click Draw box.
2. Click at three random points to draw a box of arbitrary size and location.

The Properties dialog box appears.

3. On the Command tab of the Properties dialog box, edit the values as shown in the fol-
lowing figure:
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Figure 3-37: Inner Box Properties – Command Tab

4. On the Attribute tab, change the Name to InnerBox and clickOK.

Figure 3-38: Inner Box Drawn
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Note:

The appearance attributes of this object do not matter. It will only be used as a
cutting tool to produce a ring from the outer box. After subtraction, this object will
no longer be present in the model (except as an entry in the History Tree under
the Subtract operation).

Complete the Ring
You will now subtract the inner box from the outer box to produce the desired ring shape.

1. While theObject selection mode is active, on the Draw ribbon tab, click Select by
Name.

The Select Object dialog box appears.

2. SelectGND_Ring and hold Ctrl while clicking InnerBox to select it too. Then, clickOK.

Figure 3-39: Selecting Objects for Subtraction

3. On the Draw ribbon tab, click Subtract.

The Subtract dialog box appears.

4. Verify thatGND_Ring is in the Blank Parts box, and Inner in the Tool Parts box. Then,
clickOK.
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Figure 3-40: Subtract Dialog Box

5. Clear the selection.

The model should resemble the following figure:

Figure 3-41: Ground Ring Created
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Create Extensions
You will create two extensions on the inside of the ring for connecting to the sources at each end
of the spiral inductor.

Draw the first extension as follows:

1. Draw a box freehand.

The Properties dialog box appears after you click the third point.

2. On the Command tab, edit the values as shown below:

Figure 3-42: Extension 1 Properties – Command Tab

3. On the Attribute tab change the object Name to Ext1 and clickOK.

Note:

The material appearance attributes do not matter. Once united with the ground
ring, the extensions will assume the same attributes as the ring.

4. Clear the selection.
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Figure 3-43: Extension 1 Added to Ground Ring

Draw the second extension as follows:

5. Draw a box freehand.

The Properties dialog box appears.

6. In the Command tab, edit the values as shown below:

Figure 3-44: Extension 2 Properties – Command Tab

7. On the Attribute tab change the object Name to Ext2 and clickOK.
8. Clear the selection.
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Figure 3-45: Extension 2 Added to Ground Ring

Unite Ring Objects
You will now unite the ring and its extensions into a single object. This procedure completes the
model geometry creation. Afterward, you can show the dielectric parts that were previously hid-
den.

1. UnderModel > Solids > pec in the History Tree, selectGND_Ring, Ext1, and Ext2 (in that
specific order).

2. On the Draw ribbon tab, click Unite.
3. Clear the selection.
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Figure 3-46: Ground Ring and Extensions United
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4 - Assign Boundaries and Excitations
You will now apply the boundary conditions and excitations needed to fully define the analysis
model. Before applying the excitation, you must draw two rectangles to serve as the signal
sources.

Note:

The order in which you assign boundaries can be important, as will be explained further
in the topics that follow.

This subsection contains the following topics:

l Create Signal Sources
l Assign Excitation at Sources
l Assign Radiation Boundary
l Assign Perfect E Boundary to Ground Plane
l Boundary Display (Optional)

Create Signal Sources
You will create signal sources at each end of the spiral inductor, at which excitations will be
applied. The sources are drawn as rectangles, and each one extends from the centerline of one
of the spiral inductor's end faces (termination) to the centerline of the adjacent ground ring exten-
sion's end face. The width of the source rectangles is the same as the spiral and extension width
(15 μm).

To draw the rectangles, you can snap to the midpoint of a short edge at each termination face.

Create Source1 as follows:

1. Zoom in for a close up view of the gap between the spiral's feed and the ground ring exten-
sion (the gap at the -X end of the spiral).

2. On the Draw ribbon tab, click Draw rectangle.
3. Click the following point to start the rectangle (a triangle appears to indicate the midpoint

snapping point):
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Figure 4-1: First Corner of Source 1 Rectangle

4. Click the following point to complete the rectangle:

Figure 4-2: Second Corner of Source 1 Rectangle

The Properties dialog box appears after the second click.

5. On the Attribute tab, make the following changes:
a. Change the Name to Source1.
b. Ensure that theMaterial Appearance option is not selected.
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c. Set the Color to black (column 1, row 6 of the Basic colors samples; Red: 0, Green:
0, Blue: 0).

d. Set the Transparent value to 0.4.
6. ClickOK to accept the settings and close the Properties dialog box.
7. Clear the selection.

Figure 4-3: Source 1 Drawn

Create Source2 as follows:

8. Repeat steps 1 through 10 but, this time:
l Pan to, or zoom in on, the gap at the +X end of the spiral and draw the rectangle
there.

l Name the second rectangle Source2.

When finished, the second source should look like the following figure:
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Figure 4-4: Source 2 Drawn

9. Press Ctrl+D to fit the view.

Figure 4-5: Source1 and Source2 Added to Model

Assign Excitation at Sources
You will assign lumped port excitations at Source1 and Source2.
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Apply Lumped Port Excitation at Source1:

1. UnderModel > Sheets> Unassigned in the History Tree, right-click Source1 and choose
Assign Excitation > Port > Terminal Lumped Port from the shortcut menu.

The Reference Conductors for Terminals dialog box appears.

2. Define the port settings as shown in the following figure:

Figure 4-6: Reference Conductor for Terminal – Port 1

3. ClickOK to apply the lumped port excitation.

Apply Lumped Port Excitation at Source2:

4. UnderModel > Sheets > Unassigned in the History Tree, right-click Source2 and choose
Assign Excitation > Port > Terminal Lumped Port from the shortcut menu.

5. In the Reference Conductors for Terminals dialog box that appears, specify the same set-
tings as you did for the previous port (see Port 1 figure), except for the Port Name, which
is 2 this time.

6. ClickOK to apply the lumped port excitation.

The lumped ports (1 and 2) and their associated terminal definitions are listed under Excit-
ations in the Project Manager:
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Figure 4-7: Excitations in Project Manager

With the definition of the excitations completed, you are done working on the conductors and
can now show the hidden dielectric parts.

To show all objects in the model, do the following:

7. On the Draw ribbon tab, click Show all objects in the active view.
8. Do Ctrl+D to fit the view.
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Figure 4-8: All Objects Visible

Assign Radiation Boundary
Next, assign the radiation boundary to the air body, as follows:

1. UnderModel > Solids > air in the History Tree, right-click Air and choose Assign Bound-
ary > Radiation from the shortcut menu.

The Radiation Boundary dialog box appears, which only has one setting.

2. Accept the default Name (Rad1) and clickOK.

Assign Boundaries and Excitations 4-7

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™: Silicon Spiral Inductor

Figure 4-9: Radiation Boundary Dialog Box

3. If the radiation boundary visualization is not displayed on the model, select Rad1 under
Boundaries in the Project Manager to see it:

Figure 4-10: Radiation Boundary Visualization

4. Clear the selection.
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Assign Perfect E Boundary to Ground

Important:

Because the face of the ground plane is coincident with the face of the air body, the
order in which the radiation and perfect E boundaries are applied is important. Where
the boundary conditions overlap, the latter application will override the earlier applic-
ation. It is important that the ground plane behave like a perfect E boundary and not a
radiation boundary. For this reason, you applied the radiation boundary before the per-
fect E boundary.

Assign the Perfect E boundary to the ground plane, as follows:

1. UnderModels > Sheets > Unassigned in the History Tree, right-clickGround and choose
Assign Boundary > Perfect E from the shortcut menu.

The Perfect E Boundary dialog box appears, which has only two settings.

2. Ensure that the Infinite Ground Plane option is not selected, change the Name to
PerfE_Ground, and clickOK.

Figure 4-11: Perfect E Boundary Dialog Box

3. If the perfect E boundary visualization is not displayed on the model, select PerfE_
Ground under Boundaries in the Project Manager to see it:
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Figure 4-12: Perfect E Boundary Visualization

4. Clear the selection and Save your project.

Boundary Display (Optional)
The solver view of boundaries provides a snapshot of all boundaries in the model (including
ports and boundaries you've defined as well as default conditions applied to conductors and
outer faces). It can be very useful for diagnosing problems with design setups. For example, you
can see if a necessary boundary condition has been unintentionally superseded by one applied
to a coincident face at a later time.

In the case of this example, you should verify that the perfect E boundary is in effect at the bot-
tom face instead of the coincident radiation boundary.

The solver view of boundaries works best when the model rendering mode is Wireframe, instead
of Smooth Shaded. In this way, only the boundary colors are rendered on model faces, and not
the material appearance colors.

1. Rotate the model viewpoint so that you are looking upward at it from below, and the bot-
tom face is not hidden.

2. Using the menu bar, click Render >Wireframe (or press F6).
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Now, only the edges of objects are visible.

3. Using the menu bar, click HFSS > Boundary Display (Solver View).

The Solver View of Boundaries dialog box appears.

Note:

HFSS identifies all the unique boundary conditions and ports that exist in the
model (user-applied and default).

4. Click the Visibility column heading to turn on the display of all boundaries in a single click.

Figure 4-13: Solver View of All Boundaries
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Notice that the PerfE_Ground boundary condition overrode the Rad1 boundary that was
applied to all faces of the air body. This is the correct result for this model.

5. Deselect the Visibility option for the PerfE_Ground boundary.

Notice that the color of the bottom edges is now orange, which is the ground plane object's
color (that is, material appearance). This color is not associated with any of the boundary
conditions or ports. Therefore, the solver only sees the PerfE_Ground boundary, which
was applied after the Rad1 boundary and overrode it.

6. Deselect the Visibility option for the Rad1 boundary.
7. On the Draw ribbon tab, click Orient to restore the default Trimetricmodel viewpoint.

(You do not have to access theOrient drop-down menu.)
8. Zoom in and pan the model so that you can clearly see all of the boundary colors on the

spiral inductor, ground ring, and sources:

Figure 4-14: Solver View or Conductors and Ports
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Note:

If you double-click any swatch in the Color column, you can change the color as
desired from the palette that appears. However, the overrides are only in effect
while the dialog box is open. If you close it and choose the Boundary Display
(Solver View) command again, the colors will revert to their default settings.

9. Click Close.
10. From the menu bar, click Render > Smooth Shaded (or press F7) to restore the shaded

model display.
11. Press Ctrl+D to fit the view.
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5 - Analyze the Spiral Inductor
This chapter describes how to setup and run the simulation (including assigning mesh refine-
ment). It also covers reviewing the solution data, and generating reports.

This chapter contains the following topics:
l Create Analysis Setup
l Add Frequency Sweep
l Model Validation
l Analyze the Model
l Review the Solution Data

l Profile
l Convergence
l Matrix Data
l Mesh Statistics

l Create S-Parameter vs. Frequency Plot
l Custom Equations – Output Variables
l Simulate with Solve Inside Conductors
l Results with Solve Inside Conductors

Create Analysis Setup
To create an analysis setup:

1. On the Simulation ribbon tab, click Setup > Advanced.

The Driven Solution Setup dialog box appears.

2. In theGeneral tab, edit the settings as shown in the following figure:
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Figure 5-1: Driven Solution Setup – General Tab

3. In theMesh/Solution Options tab, edit the settings as shown in the following figure:
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Figure 5-2: Driven Solution Setup – Mesh/Solution Options Tab

4. ClickOK.

Because at least one port was defined prior to completing the solution setup, the Edit Fre-
quency Sweep dialog box opens automatically. Keep this dialog box open and proceed to
the next page, where you will find the instructions for defining the frequency sweep.

Add a Frequency Sweep
The Edit Frequency Sweep dialog box should already be open. However, if you accidentally
closed it, reopen the dialog box by completing steps 1 and 2. Otherwise, skip to step 3:

1. Under Analysis in the Project Manager, select Setup1.

2. On the Simulation ribbon tab, click Sweep (Add Frequency Sweep).

The Edit Frequency Sweep dialog box appears.
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Define the sweep settings as follows:

3. In theGeneral tab, specify the following settings:

Figure 5-3: Edit Frequency Sweep – General Tab

4. In the Interpolation tab, edit the settings as in shown in the following figure:

Figure 5-4: Edit Frequency Sweep – Interpolation Tab

5. ClickOK.
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Assign Mesh Refinement
In this section you will set HFSS to refine the length of the tetrahedral elements for the spiral until
they are below the specified value.

1. UnderModel > Solids > My_Metal in the History Tree, right-click Spiral and choose
Assign Mesh Operation > Inside Selection > Length Based.

The Element Length Based Refinement dialog box appears.

2. Edit the settings as shown in the figure below and clickOK.

Figure 5-5: Element Length Based Refinement Settings

3. UnderMesh in the Project Manager, right-click Length1 and click Select Assignment to
highlight the object to which the mesh operation is assigned.
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Figure 5-6: Identifying Target Object for Mesh Operation

4. Click in the Modeler window's background area to clear the selection.

Validate and Analyze
Before running the simulation your model must pass the Validation Check.

To validate the model:

1. On the Simulation ribbon tab, click Validate.

The Validation Check window appears and the model is validated:
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Figure 5-7: Validation Check

Note:

TheMessage Manager window gives the details concerning the Boundaries and
Excitations warning. Specifically, the warning says that, Boundary "Rad1" and
Boundary "PerfE_Ground" overlap. You can disregard this warning because
you've already verified that the solver sees the correct boundary condition where
they overlap (at the bottom face of the model). To refresh your memory, return to
the Boundary Display topic. When applying the radiation boundary, you could
have selected five of the six air body faces, thus avoiding the overlap and the
warning message. But it is not necessary for you to do so, since the latter con-
dition (PerfectE_Ground) overrides the former condition (Rad1). Applying the
boundary condition to the whole object was simply more convenient.

2. If you see any other warnings or errors (aside from the overlapping PerfE_Ground and
Rad1 boundaries), recheck your steps in building and setting up the model.

3. Click Close.

To start the solution process:

4. On the Simulation ribbon tab, click Analyze All.

The solution will take a few minutes to complete, with the time depending on your com-
puter hardware.

Review Solution Data
You can review the solution data while the simulation is running. For example, you can watch the
adaptive passes in the Convergence tab and see if the solution is trending toward convergence
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or is diverging. Of course, you won't see the a complete log of the solution data until the analysis
is finished.

The solution data is presented in the Solutions dialog box, which consists of the following four
tabs. Each tab is covered in a separate subtopic:

l Profile
l Convergence
l Matrix Data
l Mesh Statistics

There are several ways to access the solution data:

l

On the Results ribbon tab, click Solution Data. Then, select the desired tab in the
Solutions dialog box.

l Right-click Results in the Project Manager and choose Solution Data from the shortcut
menu. Then, select the desired tab in the Solutions dialog box.

l Right-click Setup1 (under Analysis in the Project Manager) and directly select the solution
data tab you want to display (Profile, Convergence, Matrix Data, orMesh Statistics).

l Using the menu bar, click HFSS > Results > Solution Data. Then, select the desired tab
in the Solutions dialog box.

Review the Profile Panel
The Profile window shows you a synopsis of the simulation process, providing real time, CPU
time, and memory consumed for each phase of the process. The log includes mesh creation and
refinement, port adaptation, adaptive passes, matrix assembly (S, Y, and Z coefficients), solver,
field recovery, data transfer, frequency sweep, and more. The total real time and CPU time for
the entire solution process are also given. The more highly refined the mesh (that is, the higher
the number of tetrahedra generated), the more accurate the solution will be. Optimal results are
achieved by only refining the mesh adaptively where required (specifically, in the areas of
greatest solution error). There is a trade-off between the number of tetrahedra used and the com-
putational resources required. Increased accuracy requires more computational resources and
more time to solve.

1. Under Analysis in the Project Manager, right-click Setup1 and choose Profile from the
shortcut menu.

The Profile tab of the Solutions dialog box appears.

2. Review the profile data.
3. Keep the dialog box open and proceed to the next topic.
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Figure 5-8: Solutions Dialog Box – Profile Tab

Review the Convergence Panel
1. Select the Convergence tab of the Solutions dialog box.

The default View option is Table.

Analyze the Spiral Inductor 5-9

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™: Silicon Spiral Inductor

Figure 5-9: Convergence Table

Note:

This solution is converged (that is, a Max. Mag. Delta S result of less than or
equal to the Target value of 0.01 was achieved between consecutive adaptive
passes).

2. Select the Plot option to view a graphical representations of the convergence data:
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Figure 5-10: Convergence Plot

3. Keep the dialog box open and proceed to the next topic.

Review the Matrix Data Panel
In this tab, you can view the computed S, Y, Z, Gamma (when applicable), or Zo matrix coef-
ficients (representing scattering, admittance, impedance, propagation, and terminal char-
acteristic impedance, respectively). You can view this data for the adaptive passes, the last
adaptive pass, or the frequency sweep using the drop-down menus at the top of the dialog box.
Additionally, you can view the results at specific frequencies or display the results for all com-
puted frequencies.

1. Select theMatrix Data tab.
2. From the Simulation drop-down menus, select Setup1 and Sweep.

The S matrix for the first frequency in the sweep is shown by default. Other frequencies
are selectable via the drop-down menu in the View subtab:

Analyze the Spiral Inductor 5-11

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™: Silicon Spiral Inductor

Figure 5-11: Matrix Data – View Options

3. Select the Display All Frequencies option:
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Figure 5-12: Matrix Data

Note:

To view a real-time update of the matrix data while a solution is still being solved,
set the Simulation options to Setup1 and Last Adaptive using the drop-down
menus at the top of the dialog box.

4. Keep the dialog box open and proceed to the next topic.
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Review the Mesh Statistics Panel
As the title indicates this panel shows statistics about the mesh that was generated. More spe-
cifically, it gives a breakdown of the statistics, tabulating the data for each individual solid object
comprising the model. The data includes the number of tetrahedra generated; the minimum,
maximum , and RMS (root mean squared) edge length; the minimum, maximum, and mean tet-
rahedron volume; and the standard deviation of the tetrahedra volumes.

1. Select theMesh Statistics tab:

Figure 5-13: Mesh Statistics

Notice that the Spiral object has the number of tetrahedral element reported along with
their length and volume data. A solid mesh is generated for all objects, whether each
mesh is used or not. For this analysis, the Spiral object's Solve Inside option was deselec-
ted. So, this particular mesh was not actually used in the solution.

2. Click Close when you are done reviewing the contents of this tab.

Create S-Parameter vs. Frequency Plot

1. On the Results ribbon tab, click Terminal Solution Data Report > 2D.

The Report dialog box appears.

2. Edit the settings as shown in the following figure:
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Figure 5-14: S Parameter vs. Frequency Plot Settings

3. Click New Report but keep the dialog box open for now.

The Terminal S Parameter plot appears in a new window:
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Figure 5-15: S-Parameter vs. Frequency Plot (No_Solve_Inside)

Notice that the basic trend of the curves is as you would expect for an inductor. As the fre-
quency increases, the transmission to the second terminal decreases (green curve) and
the signal reflection at the input terminal increases. Inductors allow direct current to pass
unimpeded but increasingly attenuate the signal as the frequency increases.

Custom Equations – Output Variables
In this procedure, you will create two plots based on user-defined output variables. You will
define three output variables, R, L, andQ, and plot each of these variables versus frequency.

A real-world inductor includes the inductance (L), a parasitic series resistance (R), and parasitic
capacitance (C) in the substrate between the inductor and ground plane. The following figure is
a representative "pi" circuit for modeling a real-world spiral inductor:
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Figure 5-16: Simple "Pi" Model of a Spiral Inductor

The structure is assumed to be roughly symmetrical. So, as an approximation, the capacitance
is divided into two lumped capacitors, each with a value C/2, and each attached to one of the two
ports. For simplicity, assume that the R, L, and C values are all independent of frequency.
However, in reality, the resistance in particular will increase with frequency due to the skin effect.
Additionally, in order to easily extract values from the HFSS results, assume that the circuit is
working at a frequency well below its resonant frequency. Finally, assume that the product of the
parasitic resistance and capacitance is sufficiently low. That is, assume ωR(C/2) ≈ 0, whereω is
the frequency in radians/second.

For the purpose of this exercise, you will not extract or plot R or C values. However, the R value
is a constituent of the quality factor (Q), which will be the subject of your second output variable
and plot.

Inductance (L) vs. Frequency:

Based on the previously stated assumptions, it is possible to extract the approximate L value of
the inductor from the Y-parameter results produced by the HFSS analysis (specifically, Y11).
The equation is as follows:

L ≈ im(1/Y11)/ω = im(1/Y11) / (2·π·Freq)

Note:

Y11 is defined as the current entering the circuit at port 1 when port 2 is shorted and
port 1 is excited with a 1-Volt source.ω is the frequency in radians/second. Freq is an
internal variable, specifically the sweep frequency in Hz (or cycles/second). The 2π
factor converts the frequency to radians/second.

The Report dialog box should still be open from the preceding topic. If not, repeat the first step of
the previous procedure to reopen it.

1. In the Report dialog box, clickOutput Variables.
2. Specify the following settings to define L in theOutput Variables dialog box that appears:
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a. Type L in the Name text box.
b. Select Terminal Y Parameter from the Category drop-down menu.
c. In theQuantity list, ensure that Yt(Source1_T1, Source1_T1) is selected.
d. In the Function list, select im.
e. At the bottom of theQuantities section, click Insert Into Expression.
f. Click inside the Expression text box to place the cursor between the first par-

enthesis ( and Yt. Type 1/ to invert the Y-parameter:

Figure 5-17: Inverting the Y-Parameter

g. Place the cursor at the end of the Expression and append it by typing /(2*pi*freq) to
complete it.

h. Click Add.

The L expression is added to theOutput Variables list, and it should exactly match
the following figure:

Figure 5-18: L Output Variable Added

3. Click Done to close theOutput Variables dialog box.
4. In the Report dialog box, specify the settings shown in the following figure:
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Figure 5-19: L Plot Settings

5. Click New Report but keep the dialog box open for now.

The output variable plot (L vs. Frequency) appears in a new window:

Analyze the Spiral Inductor 5-19

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™: Silicon Spiral Inductor

Figure 5-20: L vs. Frequency Plot
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Observations:

l At approximately 14.5 GHz, the inductance (L) goes negative. 14.5 GHz is
a resonant frequency of the spiral inductor structure. At this frequency and
above, the device is no longer acting as an inductor.

l The disturbance of the L value at and near the point of resonance is an arti-
fact of the way that the L value was extracted. Remember that the assump-
tions used to simplify the L equation included the condition that operation
occurs well below the resonant frequency.

l The frequency one octave below resonance is 7.25 GHz. From 0 to 7.25
GHz, the inductance is fairly stable and consistently within the range of
2.21E-9 to 2.77E-9. From 0 GHz to two octaves below resonance (3.625
GHz), the inductance remains close to 2.26E-9 (specifically, within
±0.04E-9 or ±1.8%).

Quality Factor (Q) vs. Frequency:

Another metric often used to characterize spiral inductors is the quality factor (Q), defined as the
ratio of the imaginary part of the inductor’s impedance over the real part. Based on the pre-
viously stated assumptions, this factor can also be extracted from the Y11 parameter results.
The approximation is derived as follows:

R ≈ re(1/Y11)

L ≈ im(1/Y11)/ω

Q = ωL/R ≈ im(1/Y11) / re(1/Y11)

6. In the Report window, click theOutput Variables button again.
7. Specify the following settings to defineQ in theOutput Variables dialog box that appears:

a. TypeQ in the Name text box.
b. Select Terminal Y Parameter from the Category drop-down menu.
c. In theQuantity list, ensure that Yt(Source1_T1,Source1_T1) is selected.
d. In the Function list, select im.
e. At the bottom of theQuantities section, click Insert Into Expression.
f. Click inside the Expression text box to place the cursor between the first par-

enthesis ( and Yt. Type 1/ to invert the Y-parameter.
g. At the end of the Expression, append a forward slash (/):
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Note:

The expression is red because it is incomplete. The divide operator (for-
ward slash) causes HFSS to expect another variable. Red text indicates an
incorrect or incomplete expression.

h. In the Function list, select re.
i. Click Insert Into Expression again.
j. Click inside the Expression text box to place the cursor between re( and Yt. Type 1/

to invert the second Y-parameter.
k. Click Add.

The completed expression forQ appears in theOutput Variables table:

Figure 5-21: Q Output Variable Added

8. Click Done.

TheOutput Variables dialog box closes.

9. Edit the settings in the Report dialog box as shown in the following figure:
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Figure 5-22: Q Plot Settings

10. Click New Report and then click Close.

The output variable plot (Q vs. Frequency) appears in a new window:

Analyze the Spiral Inductor 5-23

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS™: Silicon Spiral Inductor

Figure 5-23: Q vs. Frequency Plot

Observations:

l The quality factor (Q) peaks at about 8.7. This peak occurs at approx-
imately 3.3 GHz.

l Q becomes negative at 14.5 GHz. This is the point at which the L value
went negative (while the resistance remained positive). Since the com-
ponent is no longer acting as an inductor at and above the resonant fre-
quency, theQ values in this range are not meaningful.

11. Save your project.
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Simulate with Solve Inside Conductors
In this section, you will duplicate your HFSS design, modify the copy to enable the Solve Inside
option for the Spiral conductor, and analyze the modified design. Afterward, you will compare
the results with those produced without the Solve Inside option enabled for the spiral conductor.

By default Solve Inside gets automatically deselected for metals or highly conductive materials.
The conductive material is represented by a boundary condition that removes the need to solve
inside the metal. For most projects, we recommend that you use the default settings. When
Solve Inside is selected, it generates tetrahedra inside the conductor, which may require a large
number of elements. Solve Inside can be useful for low frequency analyses of electrically small
projects to provide enhanced accuracy of sensitivity design parameters (such as the Q factor).

1. Right-click No_Solve_Inside (Terminal Network) in the Project Manager and choose
Copy from the shortcut menu.

2. Right-click Si_Spiral_Conductor at the top of the Project Manager and choose Paste.

A new design, No_Solve_Inside1 (DrivenTerminal), appears in the Project Manager
below the original one, and a new Modeler window opens.

3. Select the new design entry in the Project Manager.
4. Press F2, change the name to Solve_Inside, and press Enter.
5. Collapse the original design branch [ No_Solve_Inside (TerminalNetwork) ] and expand

the new design branch [ Solve_Inside (TerminalNetwork) ]:

Figure 5-24: New HFSS Design in Project Manager
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6. To ensure that you don't accidentally modify the wrong design, close the Spiral_Inductor –
No_Solve_Inside – Modeler window. You can use theWindowmenu to select it and then
click the X button:

l To close a maximized window, click this button near the upper right corner of the
program screen:

Figure 5-25: Closing a Maximized Window

l To close a floating (non-maximized) window, click this button in the upper right
corner of the window:

7. Use theWindowmenu to make the Spiral_Inductor – Solve_Inside – Modeler window
active (bringing it to the foreground).

8. UnderModel > Solids > My Metal in the History Tree, select Spiral.

The object's attributes are displayed in the docked Properties window.

9. In the docked Properties window, select the Solve Inside option.

Note:

TheMessage Manager window displays the following message: Solving inside a
solid with high conductivity may require a large mesh.

10. In the new design branch of the Project Manager, right-click Analysis and choose Ana-
lyze All from the short-cut menu.

This design variant will take four or five times longer to solve than the original design, due
to the adaptive meshing of the spiral conductor and the higher element count.

Results with Solve Inside
The new HFSS design has all of the output variables and plots that were defined for the original
design. However, the plot windows that are already open remain associated with the design in
which they were generated. To display the plots for the new design, you simply have to double-
click plot headings under Results in the Project Manager.
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Before displaying the plots for the modified design, let's look at the Convergence plot and Mesh
Statistics.

1. Under Solve_Inside (Terminal Network) > Analysis in the Project Manager, right-click
Setup1 and choose Convergence.

2. For the View option, choose Plot.

You can see that the solution converged in nine passes (one fewer that the previous ana-
lysis), and with a similar Max Mag. Delta S achieved.

Figure 5-26: Convergence Plot – Solve Inside Enabled for Spiral

3. Select theMesh Statistics tab.

The element count for the Spiral object is approximately 2.5 times that of the previous ana-
lysis (3242 versus 1297 for the previous analysis).
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Figure 5-27: Mesh Statistics – Solve Inside Enabled for Spiral

Note:

Your results may be different since meshing and solution convergence behavior
can vary somewhat between different computing platforms and different software
versions.

4. Click Close to dismiss the Solutions dialog box.
5. Under Solve_Inside (Terminal Network) > Results in the Project Manager, double-click

each of the following plots to generate them for the Solve_Inside design:
a. Terminal S Parameter Plot 1
b. Output Variables Plot 1
c. Output Variables Plot 2

The following plots appear in new windows:
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Figure 5-28: S-Parameters vs. Frequency Plot (Solve_Inside)
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Figure 5-29: L vs. Frequency Plot (Solve_Inside)
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Figure 5-30: Q vs. Frequency Plot (Solve_Inside)

Observations:

l Qualitatively, all three plots from the Solve_Inside design are similar to the
corresponding plots from the No_Solve_Inside design.

l The quantitative difference are somewhat difficult to perceive because the
Y scales differ between the plots from each design. The scale settings
could be adjusted to be the same for both designs. You could also add
markers to indicate the numerical value of the results at designated points.
However, there's an easier way to compare the results of two or more
plots, which will be demonstrated in the next topic.
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Direct Comparison of Results
For the best comparison of results from two different plots, the traces should be viewed within
the same plot and using the same X and Y scales. Ansys Electronics Desktop allows you to copy
plot data from traces in one plot and paste them into another plot for direct comparison using
identical scaling parameters. You will create three new plots in the second design, rename them,
and copy and paste in the traces from the first design for comparison.

1. Under Solve_Inside (DrivenTerminal) > Results in the Project Manager, select Terminal
S Parameter Plot 1, Output Variable Plot 1, andOutput Variable Plot 2 (holding down
Ctrl to select multiple items).

2. Right-click on one of the selected plot titles and choose Copy Definition from the shortcut
menu.

3. Right-click Results and choose Paste.

Three additional plots appear in the Results branch with "_1" appended to each title.

4. Right-click Terminal S Parameter Plot 1_1, choose Rename, change the name to S
Parameter Results Comparison, and press Enter.

5. Under No_Solve_Inside > Results > Terminal S Parameter Plot 1 in the Project Manager,
select both traces [dB(St(Source1_T1,Source1_T1)) and dB(St(Source1_T1,Source2_
T1)).

6. Right-click on one of the two selected traces and choose Copy Data.
7. Under Solve_Inside > Results in the Project Manager, right-click S Parameter Results

Comparison and choose Paste.

Two traces are added to the S Parameter Results Comparison plot. The red and green
traces represent the Solve_Inside results, and the blue and orange traces represent the
No_Solve_Inside results.

Note:

If the color of any trace does not match the colors in this description, select the
trace in the legend and change the Color selection in the docked Properties win-
dow.

Where a trace is directly over another, you will only see the color of the most
recently added one. If you point to a row in the legend, the associated trace will
turn green to help you identify overlapping curves.

8. Right-click in the new plot window and choose Add Note. Then, in the Add Note dialog
box, type the note exactly as shown in the following figure and clickOK (stretch the win-
dow width as needed):
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Figure 5-31: Comparison Plot Notation

9. Click and drag the borders of the yellow notation to resize it. Also, position the legend and
notation to produce a comparison plot similar to the following figure:

Figure 5-32: S Parameter Results Comparison Plot
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Now you can clearly see the divergence above 13 GHz of the dB(St(Source1_
T1,Source2_T1)) results between the two designs.

10. In the same manner as detailed in steps 4 through 9, renameOutput Variables Plot 1_1
as L Results Comparison, copy and paste the corresponding trace from the first design,
and add and position a suitable notation.

The resultant plot should look like the following figure:

Figure 5-33: L Results Comparison Plot

11. Again, in the same manner as detailed in steps 4 through 9, renameOutput Variables
Plot 2_1 asQ Results Comparison, copy and paste in the corresponding trace from the
first design, and add and position a suitable notation:

The resultant plot should look like the following figure:
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Figure 5-34: Q Results Comparison Plot

12. Save your project.
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6 - Optionally, Restore Current View
Orientations

You have completed this getting started guide.

If you prefer to use the new view orientations implemented in version 2024 R1 of the Ansys Elec-
tronics Desktop application, clear the Use Legacy View Orientation option as follows:

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is cleared:

3. ClickOK.

The settings in the 3D UI Options dialog box are global. Your choice is retained for all future pro-
gram sessions, projects, and design types that use the 3D Modeler or that produce 3D plots of
results.

Optionally, Restore Current View Orientations 6-1
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You can now save and close this project.

Optionally, Restore Current View Orientations 6-2
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